Back to overview
Degraded
Call Failure Rates
May 28, 2026 at 10:41am UTC
Affected services
Studio Backend
Web Widget & Embeds
Resolved
May 28, 2026 at 11:27am UTC
Issue is fixed, it was caused by brief network issue with our database. we will be monitoring services to ensure stability.
Affected services
Created
May 28, 2026 at 10:41am UTC
We are seeing increase call failure rates in calls, our team is actively working on it.
Affected services